LaTeX, PDF и русский язык (проблема при копировании в буфер обмена)

mcfly67

При преобразовании LaTeX => PDF в самом пдф-документе русский виден нормально, но при попытке скопировать его в буфер обмена как текст - получаются кракозябры ("Привет!" => "I?eaao!").
Пример теховского файла:

\documentclass[12pt]{article}
\usepackage[cp1251]{inputenc}
\usepackage[russian]{babel}
\begin{document}
Привет!
\end{document}

Пользуюсь TeXnicCenter, но в последнем WinShell наблюдал аналогичную ситуацию. PDF читал Adobe Reader и PDF-XChange Viewer, результаты аналогичны.
gs 8.64
MikTeX 2.8
Как добиться правильного копирования в буфер обмена?
P.S. Кстати, если выбирать режим LaTeX => PS => PDF, то пдф вообще не создается, а в ps-файле все русские буквы отсутствуют. При LaTeX => PS все нормально, но при попытке сконвертировать в pdf через gsview получаю пдф, который выглядит нормально, но в буфер обмена опять попадают кракозябры.

Elena12345

проверил на texlive-2009 под линуксом, русские буковки копируются правильно и при cp1251, и при utf8

vsjshnikova

Подключи пакет cmap.

dunkel68

Подключи пакет cmap.
Правду говорит

mcfly67

Да, действительно, пакет этот не стоял.
Но вот что странно. Раньше (где-то в районе miktex 2.4, лет пять назад) я не ставил этот пакет, и уж точно не писал

\usepackage{cmap}

но можно было нормально извлекать русские слова из пдф. Сейчас - только при таком подключении, и только в Adobe Reader (в своем любимом pdf-xchange все те же кракозябры :( )
Upd. При этом, работает только в команде

pdflatex file.tex

В остальных режимах (dvipdfm, ps2pdf) все те же кракозябры (наверное, так и должно быть?). Вроде раньше работало везде хорошо, и везде русский распознавался.
Оставить комментарий
Имя или ник:
Комментарий: